ShootersForever.com Forum Index

GoldenEye 007 Nintendo 64 Community, GoldenEye X, Nintendo 64 Games Discussion
GoldenEye Cheats, GoldenEye X Codes, Tips, Help, Nintendo 64 Gaming Community


1964 - Controller Buttons Aren't Working
Goto page 1, 2  Next
 
Post new topic   Reply to topic    ShootersForever.com Forum Index -> Online And Emulation
View previous topic :: View next topic  
The Renegadist
Secret Agent
Secret Agent


Joined: 10 Feb 2016
Posts: 343
Location: Facility Vents

 PostPosted: Sat Jan 12, 2019 8:02 pm    Post subject: 1964 - Controller Buttons Aren't Working Reply with quote Back to top

Hi, wanted to make a quick post because I'm at my wits end. I'm trying to use a GCN controller with the Wii U Mayflash adapter to do GE with 1964 and for some reason certain controls in-game aren't working.

Before anyone says the obvious, the controls work just fine in P64 with the exact same build of NRage and yes I have made sure they're bound correctly and set to 1.1 in-game. It's my theory that the mouse and keyboard controls are being forced for whatever reason because when these buttons are bound to mouse or keyboard they work just fine.

L+R and the C-Buttons aren't working.

Thanks, hope to hear back soon as I'd like to stream this tonight.
_________________
 
View user's profile Send private message
Carnivorous
Moderator
Moderator


Joined: 15 Oct 2016
Posts: 497
Location: Finland

 PostPosted: Sat Jan 12, 2019 8:16 pm    Post subject: Reply with quote Back to top

This is likely the same issue as Lukas01. Unfortunately I haven't experienced this issue with my own controllers using N-Rage - as a last resort you could try deleting xinput1_3.dll and see if it works
 
View user's profile Send private message
The Renegadist
Secret Agent
Secret Agent


Joined: 10 Feb 2016
Posts: 343
Location: Facility Vents

 PostPosted: Sat Jan 12, 2019 8:20 pm    Post subject: Reply with quote Back to top

Didn't work for me, still getting the same issue.
_________________
 
View user's profile Send private message
Carnivorous
Moderator
Moderator


Joined: 15 Oct 2016
Posts: 497
Location: Finland

 PostPosted: Sat Jan 12, 2019 8:31 pm    Post subject: Reply with quote Back to top

Okay, delete the MI plugins and NRage_Input_V2_beta.dll from 1964 and try again
 
View user's profile Send private message
The Renegadist
Secret Agent
Secret Agent


Joined: 10 Feb 2016
Posts: 343
Location: Facility Vents

 PostPosted: Sat Jan 12, 2019 8:35 pm    Post subject: Reply with quote Back to top

No luck.
_________________
 
View user's profile Send private message
Carnivorous
Moderator
Moderator


Joined: 15 Oct 2016
Posts: 497
Location: Finland

 PostPosted: Sat Jan 12, 2019 8:38 pm    Post subject: Reply with quote Back to top

That sucks - I haven't got a clue why N-Rage is breaking like that. The original input plugin code is same as the original 1964 0.8.5. codebase except for extra memory hooks which are bypassed if MI isn't used.

I'd suggest asking someone from the N-Rage dev team but both members appear to be inactive ¯\_(ツ)_/¯ Maybe someone from PJ64 may be able to help
 
View user's profile Send private message
The Renegadist
Secret Agent
Secret Agent


Joined: 10 Feb 2016
Posts: 343
Location: Facility Vents

 PostPosted: Sat Jan 12, 2019 8:40 pm    Post subject: Reply with quote Back to top

It has to be an emulator or config issue because if bound to mouse or keyboard it works just fine.
_________________
 
View user's profile Send private message
Carnivorous
Moderator
Moderator


Joined: 15 Oct 2016
Posts: 497
Location: Finland

 PostPosted: Sat Jan 12, 2019 8:46 pm    Post subject: Reply with quote Back to top

I wish I could help debug this issue - but I cannot replicate it. Both controllers I own are able to bind with N-Rage (360 controller, USB gamepad)
 
View user's profile Send private message
The Renegadist
Secret Agent
Secret Agent


Joined: 10 Feb 2016
Posts: 343
Location: Facility Vents

 PostPosted: Sun Jan 13, 2019 9:25 am    Post subject: Reply with quote Back to top

Do you own a Mayflash GCN adapter for PC, that's what I'm using.

Works 100% on P64 which leads me to believe it isn't Nrage or the adapter. It HAS to be the emulator itself because I can bind Mouse + Keyboard to these buttons and they work no problem. Something is forcing L and R + C-Buttons not to work.

I've noticed when setting the aim to "Toggle" in-game you already start aiming so something is telling 1964 to have aim always on.

Is there a way we can compile 1964 without the mouse injector?
_________________
 
View user's profile Send private message
Carnivorous
Moderator
Moderator


Joined: 15 Oct 2016
Posts: 497
Location: Finland

 PostPosted: Sun Jan 13, 2019 9:46 am    Post subject: Reply with quote Back to top

I do not own a Mayflash GCN adapter for PC. I tried both of my controllers, L/R and C-buttons worked in-game as well as toggle aiming mode. I simply cannot replicate this issue with my copy of 1964, I've also tried this on another PC and it worked as well. This was tested with a newly extract copy of the 1964 bundle

Quote:
Is there a way we can compile 1964 without the mouse injector?

All MI related code for GE and PD are disabled when not using the mouse injector

I think you should give up with 1964 and just use PJ64 with it's own native support. There isn't any reason to use 1964 with a controller
 
View user's profile Send private message
The Renegadist
Secret Agent
Secret Agent


Joined: 10 Feb 2016
Posts: 343
Location: Facility Vents

 PostPosted: Sun Jan 13, 2019 9:55 am    Post subject: Reply with quote Back to top

Except 60FPS support because P64 can't handle any plugin I throw at it on my PC, not even Jabo.
_________________
 
View user's profile Send private message
Carnivorous
Moderator
Moderator


Joined: 15 Oct 2016
Posts: 497
Location: Finland

 PostPosted: Sun Jan 13, 2019 9:59 am    Post subject: Reply with quote Back to top

If you want to try a 1964 build without any mouse injector related code, you can use stolen's original 1964 build. If it works I can figure out what broke between codebases
 
View user's profile Send private message
The Renegadist
Secret Agent
Secret Agent


Joined: 10 Feb 2016
Posts: 343
Location: Facility Vents

 PostPosted: Sun Jan 13, 2019 10:01 am    Post subject: Reply with quote Back to top

Carnivorous wrote:
If you want to try a 1964 build without any mouse injector related code, you can use stolen's original 1964 build. If it works I can figure out what broke between codebases


Sounds good, I'll report back on my findings.
_________________
 
View user's profile Send private message
The Renegadist
Secret Agent
Secret Agent


Joined: 10 Feb 2016
Posts: 343
Location: Facility Vents

 PostPosted: Sun Jan 13, 2019 10:11 am    Post subject: Reply with quote Back to top

It didn't work too, guess I'm **** until I order a Raphnet adapter and even then there's no guarantee it will work.
_________________
 
View user's profile Send private message
Carnivorous
Moderator
Moderator


Joined: 15 Oct 2016
Posts: 497
Location: Finland

 PostPosted: Sun Jan 13, 2019 10:14 am    Post subject: Reply with quote Back to top

Ah that's a shame, the Raphnet adapter should work as it supports PJ64 plugin spec
 
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ShootersForever.com Forum Index -> Online And Emulation All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Cobalt 2.0 BB theme/template by Jakob Persson.
Copyright 2002-2004 Jakob Persson


Powered by BB 01, 02 BB Group

 


Please Visit My Other Sites: GoldenEyeForever.com | GrandTheftAutoForever.com

Got kids? Check out my Dora The Explorer site with games and coloring pages!

Our forums feature Nintendo 64 games, GoldenEye 007 N64 New Maps and Missions, GoldenEye Cheats, N64 Emulator, Gameshark, GoldenEye Multiplayer and more!

[ Privacy Policy ]