ShootersForever.com Forum Index

Wii GoldenEye, GoldenEye N64, Nintendo 64, N64 Emulator, Xbox 360 Video Games
GoldenEye Cheats, Xbox 360, Wii GoldenEye, Nintendo 64, N64 Emulator, Video Game Forums


GoldenEye X help

 
Post new topic   Reply to topic    ShootersForever.com Forum Index -> GoldenEye X
View previous topic :: View next topic  
madmax386
Agent
Agent


Joined: 30 Apr 2008
Posts: 192
Location: New Zealand

 PostPosted: Fri Jun 26, 2015 8:19 pm    Post subject: GoldenEye X help Reply with quote Back to top

Ok so i have a bit of a ''odd'' problem here that i hope one of you guys could help me out on.

I like too play GE/PD/GE:X on my mouse and keyboard @ 60fps @4k with "stolens" 1964 60fps mouse injector build, unfortunately the mouse injector only supports up to GE:5C-i so my new GE:X5D only runs at 30fps. So i need to change "something" in GE:X 5D to make it look like 5C-i so i can run at 60fps Smile I tried using a rom-renamer to make 5D's crs's the same as 5c-i's,i was hoping that would solve the issue but unfortunately the game does not boot. any ideas on what i can do to make 5D look the same as 5c-i?


Here is a quote from the readme for the 60fps build.
"The Mouse Injector has a PD speed-hack, which forces PD to run at 60fps. This will only trigger when the Mouse Injector detects PD is running at 30fps. There will be some situations when PD cannot be forced to run at 60fps. To minimize stutter."

Edit: the reason why i think the mouseinjector/stolens 1964 only suports up to 5C-i is because thats the highest verson that is listed in his 1964.ini file

[BCF26F59-B5CE50B9-C:45]
Game Name=GoldenEye X
Comments=Playable! (Disable RSP)
Alternate Title=GoldenEye X (5c-i Cloudless)
EEPROM Size=3

[4C3BB3E7-24FB6E5F-C:45]
Game Name=GoldenEye X
Comments=Playable! (Disable RSP)
Alternate Title=GoldenEye X (5c-i Clouds)
EEPROM Size=3
 
View user's profile Send private message Send e-mail Yahoo Messenger MSN Messenger
Fillerthefreak
Secret Agent
Secret Agent


Joined: 29 Mar 2014
Posts: 284
Location: Canada

 PostPosted: Fri Jun 26, 2015 8:33 pm    Post subject: Reply with quote Back to top

I'd advise you to not use the mouse injector, heard it has a couple viruses in it.

An alternative is to use the N-rage plugin and map the control stick to the mouse movements.

And PD should run at 60 FPS at default on 1964 Ultrafast on over clocking it to 6X. I have had a couple crashing issues on using Ultrafast's default timing, I suggest using Jabo's audio plugin and Sync game to audio for the best frame-rate.

And running GE:X at 4K seems a bit overkill. Try running at a lower screen size to reduce lag.

Also, here's some suggestions to reduce lag on GE:X (On Ultrafast 3.0)

Goto Rom Properties and set the following

Hardware

-Counter factor of 1

-8MB

-All used save type

-Max IV limit is auto sync

-Use TLB is yes

-16 KB EEPROM

Compiler

-Dyna complier

-Delay DMA

-Protect Memory

-Assume 32 bit is set to No

-Register caching is set to yes

-CP1 unusable exceptions set to yes

-Link code blocks set to yes

-Two pass compiler set to yes

Plugins

-Framebuffer depends on plugin and computer speed

-RSP timing is set to off for me.

Use whatever plugin you find the fastest.

And, you can also edit the Rom config INI file to recognize GE:X as Perfect Dark. This fixes the CamSpy not working in GE:X.
_________________
This is a signature, why did you read this?
 
View user's profile Send private message
madmax386
Agent
Agent


Joined: 30 Apr 2008
Posts: 192
Location: New Zealand

 PostPosted: Fri Jun 26, 2015 8:52 pm    Post subject: Reply with quote Back to top

Fillerthefreak wrote:
I'd advise you to not use the mouse injector, heard it has a couple viruses in it.

An alternative is to use the N-rage plugin and map the control stick to the mouse movements.

And PD should run at 60 FPS at default on 1964 Ultrafast on over clocking it to 6X. I have had a couple crashing issues on using Ultrafast's default timing, I suggest using Jabo's audio plugin and Sync game to audio for the best frame-rate.

And running GE:X at 4K seems a bit overkill. Try running at a lower screen size to reduce lag.

Also, here's some suggestions to reduce lag on GE:X (On Ultrafast 3.0)

Goto Rom Properties and set the following

Hardware

-Counter factor of 1

-8MB

-All used save type

-Max IV limit is auto sync

-Use TLB is yes

-16 KB EEPROM

Compiler

-Dyna complier

-Delay DMA

-Protect Memory

-Assume 32 bit is set to No

-Register caching is set to yes

-CP1 unusable exceptions set to yes

-Link code blocks set to yes

-Two pass compiler set to yes

Plugins

-Framebuffer depends on plugin and computer speed

-RSP timing is set to off for me.

Use whatever plugin you find the fastest.

And, you can also edit the Rom config INI file to recognize GE:X as Perfect Dark. This fixes the CamSpy not working in GE:X.


I know of and have read all about the so called "virus's" with this injector i have used it from day dot with no issues and there are threads on here discussing about how some antivirus are just giving it false positives, so i am well aware of the "risks" im taking using this injector.

I can run GE PD and GE:X 5C-i all fine@ 60fps @ 4k, 5D is the issue, i will try 1964 ultrafast, but im not to fond of mapping the mouse to the control stick, well the last time i tried that was some time ago... so i geuss i could try it out again.
EDIT:
SWEET! got it working now, i had to add 5D's info into the 1964.ini now it runs silky smooth... Thanks for your time and help.


Last edited by madmax386 on Fri Jun 26, 2015 9:07 pm; edited 1 time in total
 
View user's profile Send private message Send e-mail Yahoo Messenger MSN Messenger
Fillerthefreak
Secret Agent
Secret Agent


Joined: 29 Mar 2014
Posts: 284
Location: Canada

 PostPosted: Fri Jun 26, 2015 9:06 pm    Post subject: Reply with quote Back to top

The emulator may just be treating the new patch as a new game.

Try re-adjusting the settings to the last patch. And even copy the data from the INI files

Also, the ROM info section on 1964 Ultrafast should give you some info for making GE:X recognize as a game (I think the new patches use different ROM CRC info)

Here's what I got

Internal name: GoldenEye X

CRC1: A4844AA2

CRC2: 8E13A961

Country: USA (0x45)

There variables are different than PD, so I assume they do something different, then.

Also, if you're daring. Try a counter factor of 0. Heard it's very unstable, though.

EDIT: This may also be why Everdrives now have an issue with GE:X.
_________________
This is a signature, why did you read this?
 
View user's profile Send private message
madmax386
Agent
Agent


Joined: 30 Apr 2008
Posts: 192
Location: New Zealand

 PostPosted: Fri Jun 26, 2015 9:11 pm    Post subject: Reply with quote Back to top

Fillerthefreak wrote:
The emulator may just be treating the new patch as a new game.

Try re-adjusting the settings to the last patch. And even copy the data from the INI files

Also, the ROM info section on 1964 Ultrafast should give you some info for making GE:X recognize as a game (I think the new patches use different ROM CRC info)

Here's what I got

Internal name: GoldenEye X

CRC1: A4844AA2

CRC2: 8E13A961

Country: USA (0x45)

There variables are different than PD, so I assume they do something different, then.

Also, if you're daring. Try a counter factor of 0. Heard it's very unstable, though.

EDIT: This may also be why Everdrives now have an issue with GE:X.


SWEET! got it working now, i had to add 5D's info into the 1964.ini now it runs silky smooth... Thanks for your time and help.

and yea you were right it was treating it as a new game after adding this info into the .ini it worked like a charm
''[A4844AA2-8E13A961-C:45]
Game Name=GoldenEye X
Comments=Playable! (Disable RSP)
Alternate Title=GoldenEye X (5D Cloudless)
EEPROM Size=3''

I have my 1st Lan next weeked so i just wanted to get everything running smooth and looking good so i can show the people at the lan how far GE has came lol.z
 
View user's profile Send private message Send e-mail Yahoo Messenger MSN Messenger
Fillerthefreak
Secret Agent
Secret Agent


Joined: 29 Mar 2014
Posts: 284
Location: Canada

 PostPosted: Fri Jun 26, 2015 9:22 pm    Post subject: Reply with quote Back to top

Yeah, I noticed that info kinda changed with the newer patches, dunno why.

If you have any other questions about the GE:X, feel free to ask. As I'm here pretty often.

Off-topic: I have a problem, too. Rice's graphics plugin has an issues on 1964 Ultrafast where the trees in Surface render as giant red squares. This does not happen with any other emulator and graphics plugin setting.



This only happens on Rice with 1964, so it might not be a worry to you. Looks fine on almost all other plugins.
_________________
This is a signature, why did you read this?
 
View user's profile Send private message
madmax386
Agent
Agent


Joined: 30 Apr 2008
Posts: 192
Location: New Zealand

 PostPosted: Sat Jun 27, 2015 5:03 pm    Post subject: Reply with quote Back to top

Fillerthefreak wrote:
Yeah, I noticed that info kinda changed with the newer patches, dunno why.

If you have any other questions about the GE:X, feel free to ask. As I'm here pretty often.

Off-topic: I have a problem, too. Rice's graphics plugin has an issues on 1964 Ultrafast where the trees in Surface render as giant red squares. This does not happen with any other emulator and graphics plugin setting.



This only happens on Rice with 1964, so it might not be a worry to you. Looks fine on almost all other plugins.


Yea nah i have never seen that issue, but i only use Glide64 unless im playing Multiplayer split screen i use jabos 1.6.1.

ill jump on now n test out the rice plugin and see if i get the same issue.

Yea check these forums daily...... since 2008...... infact probably before then because i browsed these forums alot before i joined Wink , how far has GE came tho, its great.
 
View user's profile Send private message Send e-mail Yahoo Messenger MSN Messenger
AL64inthedark
00 Agent
00 Agent


Joined: 18 Sep 2014
Posts: 435
Location: France

 PostPosted: Sat Jun 27, 2015 8:28 pm    Post subject: Reply with quote Back to top

How are the death sequences in solo handled by the GE engine ?
Is that a script with action block or something like that, or it is hardcoded ?

I was wondering if it possible to bring back that, or just create something totally original (for other mods eventually).
 
View user's profile Send private message MSN Messenger
Fillerthefreak
Secret Agent
Secret Agent


Joined: 29 Mar 2014
Posts: 284
Location: Canada

 PostPosted: Sat Jun 27, 2015 11:24 pm    Post subject: Reply with quote Back to top

AL64inthedark wrote:
How are the death sequences in solo handled by the GE engine ?
Is that a script with action block or something like that, or it is hardcoded ?

I was wondering if it possible to bring back that, or just create something totally original (for other mods eventually).


You mean the bloody screen effect? My guess is that it's just an animated texture that spawns from a trigger activated from a player's death and overlaps over their screen view.

I have actually never looked into GE/PD internally. All I know is that they may look the same at first glance, but they're very different in terms of how they function.

There maybe is an action block of sorts to restore that feature, though. Don't know because I don't understand the game's internally.

One thing I really want to know if there's a way to restore the "auto duck" feature GE had. Where going to a place that could on be access by ducking would make you duck, and you'd un-duck if you left the area.
_________________
This is a signature, why did you read this?
 
View user's profile Send private message
Trevor
007
007


Joined: 15 Jan 2010
Posts: 812
Location: UK, Friockheim OS:Win10-Fast PerfectGold:Latest

 PostPosted: Sun Jun 28, 2015 3:39 am    Post subject: Reply with quote Back to top

I have no real idea but my guess would be the following.

As the textures used for GE have been discovered you could inject them into PD (or maybe they are still there, there are a lot left over from GE in PD)

Then track the command to make the screen red and insert the 42 TextRec(Texture(number), screen-size) commands into that point.

If you wanted the 3 replays of death that would be very dificult I think.

heh, cool idea I had was to have the death replays replace the stars behind the KIA screen but thats even more improbable.

Trev
_________________
 
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    ShootersForever.com Forum Index -> GoldenEye X All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Cobalt 2.0 BB theme/template by Jakob Persson.
Copyright 2002-2004 Jakob Persson


Powered by BB 01, 02 BB Group

 


Please Visit My Other Sites: GoldenEyeForever.com | GrandTheftAutoForever.com

Our forums feature Nintendo 64 games, GoldenEye 007 N64 New Maps and Missions, GoldenEye Cheats, N64 Emulator, Gameshark, GoldenEye Multiplayer and more!!!

[ Privacy Policy ]